Tracking Page Outage
Resolved
Apr 22, 2026 at 9:18am UTC
Root Cause Analysis - Tracking Page Downtime
The tracking page went down because the backend application serving the tracking pages’ had a scheduled maintenance where it’s security group was updated.
During this update, port 80 [HTTP] was removed as part of our internal effort to move all requests on HTTPS only.
One of the tracking page APIs was dependent on port 80 to serve the frontend - tracking pages. As a result, incoming requests were silently blocked. Since internal systems remained operational and healthy, no alerts were triggered.
The issue was identified and resolved by reverting the changes and restoring port 80 access.
Preventive Actions being taken to avoid this issue from happening in future:
- Uptime monitoring on the tracking page backend API using their party uptime monitoring tools.
- Before modifying or removing any security group rules, it will be ensured that no active services or traffic depend on them.
Affected services
Updated
Apr 22, 2026 at 4:39am UTC
The issue has been resolved, and the tracking page is now functioning normally.
We recommend validating the flow from your end and reaching out if you encounter any further issues.
Thank you for your patience.
Affected services
Created
Apr 22, 2026 at 3:47am UTC
We are currently experiencing an issue with the tracking page, and it is temporarily unavailable. Our team is actively working to resolve the issue at the earliest.
Estimated Resolution Time: 10:00 AM
We’ll continue to share updates on the progress.
Affected services