Back to overview

Issue with Reports Generation

Apr 17, 2026 at 6:09am UTC
Affected services
Dashboard - B2C

Resolved
Apr 17, 2026 at 6:09am UTC

The reporting issue has been resolved.