Intermittent Issues with Tracking Page
Resolved
Jul 30 at 06:36am UTC
Root Cause Analysis (RCA) – SSL Error on Tracking Pages & Returns Portal
Incident Summary:
On 30th July, users experienced SSL certificate errors when accessing Clickpost’s tracking pages and returns portal. This was due to an ongoing incident at Cloudflare, which affected SSL termination for proxied domains.
Root Cause:
Cloudflare was experiencing a service disruption impacting SSL certificate resolution for proxied domains (refer: Cloudflare Incident: https://www.cloudflarestatus.com/incidents/dmz0f4sm2tmg). To mitigate the impact, we temporarily disabled proxying for all our domains last night. While this served as an immediate workaround, it led to the SSL certificate mismatch for services hosted behind Cloudflare.
Resolution:
We have re-enabled Cloudflare proxying on all affected domains. As of now, SSL certificates are correctly served via Cloudflare, and services are fully operational.
Preventive Measures:
• Enhanced monitoring has been set up to detect SSL resolution anomalies earlier.
• We are evaluating fallback strategies to ensure continued secure access in case of third-party CDN disruptions.
We sincerely apologize for any inconvenience caused and appreciate your patience.
Affected services
Updated
Jul 30 at 06:19am UTC
The issue has now been resolved.
We request you to please refresh the tracking page and validate the flow from your end. While our team continues to actively monitor the system, please don’t hesitate to reach out to support@clickpost.in in case you still face any issues.
We’ll be happy to assist you further!
Affected services
Updated
Jul 30 at 04:54am UTC
The team is still working on resolving the Tracking Page outage. The issue is taking slightly longer than expected due to SSL certificate issue across a few domains.
Revised Resolution ETA: ~1 hour
We sincerely appreciate your patience and will continue to keep you posted on further updates.
Affected services
Created
Jul 30 at 04:20am UTC
We are experiencing an outage in the Tracking Pages. Please be assured that the team is proactively working to resolve the issue.
Resolution ETA: 30 mins
We shall keep you posted with further updates.
Affected services